编译php中遇见的库缺失(not found)问题

/ 0 评 / 阅读 385

编译php7的时候老是遇到 xxx not found 的问题,这里总结一下。 首先是基本的依赖:

openssl libssl-dev make curl libcurl4-gnutls-dev libjpeg-dev libpng-dev libmcrypt-dev libreadline6 libreadline6-dev autoconf

直接apt-get或yum安装。 configure时如果遇到 xxx not found 之类的错误,对应安装相应的依赖:

bison -> bison

xml2-config -> libxml2-dev

OpenSSL -> libcurl4-openssl-dev pkg-config

BZip2 -> libbz2-dev

jpeglib.h -> libjpeg-dev

png.h -> libpng-dev

xpm.h -> libxpm-dev

freetype-config -> libfreetype6-dev

gmp.h -> libgmp-dev libgmp3-dev ln -s /usr/include/x86_64-linux-gnu/gmp.h /usr/include/gmp.h

mcrypt.h -> libmcrypt-dev

mysql -> libmysqlclient15-dev

pspell -> libpspell-dev

recode.h -> librecode-dev

参考文章:

How to install PHP7 on Ubuntu or Debian

在ubuntu 14.04上安装php7

发表评论

电子邮件地址不会被公开。 必填项已用*标注