webdriver mousemove 提示 at least an element or offset should be set

/ 0 评 / 阅读 291

被这个问题卡了一上午。

通过webdriver操作浏览器移动鼠标的时候,明明传入了需要移动的偏移offset,却还依旧提示 at least an element or offset should be set,而且还是时不时的出现,见鬼了。

谷歌一番,在 https://github.com/angular/protractor/issues/4970 有个人提到传入的offset必须是int,这才恍然大悟。

必须吐槽php啊,弱类型写起来很快,但坑起来也很坑。不过也怪我,没看函数声明doc,作者已经在注释里写了int了。

发表评论

电子邮件地址不会被公开。 必填项已用*标注